[not a bug] teleport didn't work properly at small lvl with Q's

Bug reports and discussion about bugs.
Post Reply
User avatar
tangar
Posts: 1238
Joined: Tue Mar 03, 2015 3:49 pm
Contact:

[not a bug] teleport didn't work properly at small lvl with Q's

Post by tangar » Mon Apr 23, 2018 8:15 am

This is the moment of meeting 'Q' pit at -1350 Angband:
https://youtu.be/dDm2u5hUMbk?t=12m23s

To see what happened I recommend to turn on 'slow' speed at youtube (x0.25)

1) 12:26 I had first spawn on me (W&L)
// right after it happened I pushed hotkey to read teleportation scroll
2) 12:27 I was teleported RIGHT near the spot where I was, just _2_ tiles to the south from my previous position
3) 12:29 I pushed tele hotkey again and was teleported away, saw that more 'Q's comming and used tele one more time which brought me right to the spot I was at first ;) Actually at this moment I thought that my tele macro is broken (cause I didn't recognized that it worked after 1st attempt to move me 2 tiles away).

Teleportation description from the guide:
The normal 'teleportation' as provided by scrolls, staves or used by monsters
which has a very long range and also tries to keep a certain minimum range to
make sure you actually get away from trouble.
Right after I died I though that my teleport macro failed somehow; only after I watched video record in slow mode I noticed that I actully teleported, but only 2 tiles away :lol:

What causes this bug (assumptions):
1) too small lvl to find 'right' position for teleport (but actually this lvl had some more space at south)
2) too much 'Q' at small lvl somehow interfere with player's teleportation

Death file:
http://angband.oook.cz/ladder-show.php?id=21573
Tangar's guides, addons, mods & fonts: My tavern @ mmoforum.org ||||||| Russian TomeNet page
http://youtube.com/GlazGame — streams in English // http://youtube.com/StreamGuild — streams in Russian
My chars @ angband.oook.cz

User avatar
the_sandman
Developer
Posts: 148
Joined: Sun Dec 13, 2009 6:52 pm

Re: [critical] teleport didn't work properly at small lvl with Q's

Post by the_sandman » Mon Apr 23, 2018 2:19 pm

tangar wrote:
Mon Apr 23, 2018 8:15 am
Teleportation description from the guide:
The normal 'teleportation' as provided by scrolls, staves or used by monsters
which has a very long range and also tries to keep a certain minimum range to
make sure you actually get away from trouble.

User avatar
tangar
Posts: 1238
Joined: Tue Mar 03, 2015 3:49 pm
Contact:

Re: [critical] teleport didn't work properly at small lvl with Q's

Post by tangar » Mon Apr 23, 2018 6:55 pm

the_sandman, so this is not a bug? Did teleport worked correct in that situation?
Tangar's guides, addons, mods & fonts: My tavern @ mmoforum.org ||||||| Russian TomeNet page
http://youtube.com/GlazGame — streams in English // http://youtube.com/StreamGuild — streams in Russian
My chars @ angband.oook.cz

mikaelh
Developer
Posts: 181
Joined: Sun Dec 13, 2009 3:18 pm

Re: [critical] teleport didn't work properly at small lvl with Q's

Post by mikaelh » Mon Apr 23, 2018 7:45 pm

At 12:27 you got teleported by a monster:

The Lesser black reaver commands you to return.

This is the TELE_TO spell. Basically the monster will teleport you right next to it. So I don't see anything broken here. Just two unlucky teleportations and an unlucky encounter with a Q pit.

User avatar
tangar
Posts: 1238
Joined: Tue Mar 03, 2015 3:49 pm
Contact:

Re: [not a bug] teleport didn't work properly at small lvl with Q's

Post by tangar » Mon Apr 23, 2018 9:03 pm

I see, thanks for an explanation.

/me renamed topic
Tangar's guides, addons, mods & fonts: My tavern @ mmoforum.org ||||||| Russian TomeNet page
http://youtube.com/GlazGame — streams in English // http://youtube.com/StreamGuild — streams in Russian
My chars @ angband.oook.cz

Post Reply